Issues Adding GE 12730 Z-Wave Fan Controller to Home Assistant

I recently moved to HassIO for my Home Assistant instance and migrated off a Raspberry Pi 3B to an Intel NUC. As part of that process I decided to rebuild my Z-Wave network from scratch. I had built much of the network without using a secure network key, so this was a good opportunity to enhance security too.

Once I finished copying over my configuration from the Pi to the NUC, I used the Z-Wave control panel in Home Assistant to remove all my devices from the Z-Wave network and then added them back using the Add Node Secure button. The only device I had a lot of trouble with was a GE Z-Wave fan controller (model 12730). It had worked just fine previously, but it didn’t want to join the new Z-Wave network for some reason.

I tried to add it several times, including with the non-secure Add Node button. Finally, I came across this suggestion to exclude it first (even though it wasn’t technically included in my new Z-Wave network yet). Watching the Open Z-Wave log (using the Tail button in the control panel is perfect for this) I could see that something was happening when I used the Remove Node button in Home Assistant and clicked on the fan switch. There was an error message about “NodeID 0 returned” and then the remove node command showed as “failed” in the log. I wasn’t sure if this was a good or bad sign; I just hoped the suggestion might actually do the trick!

Using the “Tail” button makes debugging Z-Wave issues much easier.

I waited about a minute for the fan switch to stop trying to exclude from the network, turned it off, then I used the Add Node Secure button and turned the fan switch on again. Sure enough, it showed up in Home Assistant!

Except it was showing as a light dimmer, not a fan switch. Fortunately a restart of Home Assistant fixed that issue. I’m not sure why the correct device type wasn’t detected initially, but I have found that it is a good practice to save a snapshot and restart Home Assistant after adding a new Z-Wave device for quirks like this.

Now my GE 12730 fan controller works as expected. I should also note that there is a Z-Wave Plus version of this switch that works great with Home Assistant and I’m using it in another room with no issues. Z-Wave Plus devices have a number of improvements over previous generation devices.

Leave a Reply

Your email address will not be published. Required fields are marked *